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Pivot Tables
Being able to analyse all the data in your worksheet can help you make better business
decisions. But sometimes it’s hard to know where to start, especially when you have a lot of
data. Excel can help you by recommending and then automatically creating PivotTables,
which are a great way to summarize, analyse, explore, and present your data.
Make sure your data has column headings or table headers, and that there are no blank
rows.
• Click any cell in the range of cells or table.
• Click on the Insert Tab and click on
Recommended PivotTables.
• In the Recommended PivotTables dialog box, click
any PivotTable layout on the left to get a preview
to the right, and then pick the one that shows the
data the way you want.

•
•

Click OK.
Excel places the PivotTable on a new worksheet and shows the Field List so you can
further rearrange the PivotTable data as needed.

Note: Using a recommended PivotTable is a quick way to get started on the right path.
However, you can still create an empty PivotTable to add your own fields and layout. Just
click PivotTable on the Insert tab, instead of Recommended PivotTables.
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•

All pivot table options are available within the Pivot Table Tools under both the
Analyze and Design tabs. These are displayed once you click anywhere on the Pivot
Table.

•

You can re-arrange the layout of your pivot table by dragging the headings from the
field list on the right hand side to the Report filter, column labels, row labels and
values areas beneath
You don’t have to use all the fields and a little experimentation is required initially to
decide what layout works best.
 The heading in the values field nearly always represents a numeric value. A value
you would want to sum, average or count.
 The heading in the Report Filter is something you might want to filter an entire
set of data on. In this example it might be useful to compare the different stores.

•

▪

Using the drop down arrows on the headings you can filter the data.

Changing the Value Field Settings
By default if you have a numeric value in the Values field
it will be summed. If you want to get the average or
count the number of values, do the following
▪

Click on the Arrow beside the Sum of  Value
Heading or right click somewhere within the Units
area of the Pivot Table

▪

From the menu that displays select Value Field
Settings… and choose the required function e.g. Average, Max, Min, Count

▪

The number format can also be changed here e.g. if you required Currency with 2
decimal places

▪

Click OK
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Refreshing the Data
If changes are made to the original data you must Refresh your pivot table to reflect these
changes. The Refresh command is located under the Anyalyze Tab of Pivot Table Tools.

Refresh Data when opening a file
There is an option that can be turned on that will refresh the data when opening the file.
▪

From the PivotTableTools click Options Tab then within Pivot Table Group, Options
command

▪

Click on the Data Tab and tick Refresh the
data when opening the file

▪

Click on OK
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Grouping Data
In the row and column label areas of a PivotTable report, you can group the items in a field
in a custom way. Grouping the data can help you to isolate a subset of data that satisfies
your specific needs, and that cannot be easily grouped in other ways, such as sorting and
filtering. You may wish to group using one of the following:
• Group numbers in numeric fields
• Group dates or times
• Group selected items
Example of grouping by date:
1. In the PivotTable report, click any date or time in the date or time
field, and then on the Options tab, in the Group group, click Group
Field.
2. The following screen appears:

3. Leave the auto information unless you wish to set your own start and end date.
4. In the By box, click one or more date or time periods for the groups. Group by
Months is selected by default, but you can click it to deselect it.
5. To group items by weeks, in the By box, make sure that Days is the only time period
selected, and then in the Number of days box, click 7. You can then click additional
time periods to group by, such as Months.
6. Click on OK.
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Pivot Charts
A PivotChart provides a graphical representation of the data in a PivotTable report, in this
case is called the associated PivotTable report. Like a PivotTable, a PivotChart is interactive.
When you create a PivotChart, PivotChart filters are displayed in the chart area so that you
can sort and filter the underlying data of the PivotChart report. Changes that you make to
the field layout and data in the associated PivotTable are immediately reflected in the
PivotChart.
A PivotChart displays data series, categories, data markers, and axes just as standard charts
do. You can also change the chart type and other options such as the titles, the legend
placement, the data labels, and the chart location.

Creating a Pivot Chart
•

Click any cell in the range of cells.

•

Click on the Insert Tab and click on Pivot Chart and select Pivot Chart.

•

Click on OK

•

Create the Pivot Chart by dragging the fields as required to the FILTERS, LEGEND
(SERIES), AXIS (CATEGORY) AND VALUES area at the bottom right of the screen.

•

To avail of all the Pivot Chart Tools options click anywhere on the chart created and
click on the Analyze, Design or Format Tabs
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Slicer
Slicers are easy-to-use filtering components that contain a set of buttons that enable you to
quickly filter the data in a PivotTable report, without the need to open drop-down lists to
find the items that you want to filter.
When you use a regular PivotTable report filter to filter on multiple items, the filter indicates
only that multiple items are filtered, and you have to open a drop-down list to find the
filtering details. However, a slicer clearly labels the filter that is applied and provides details
so that you can easily understand the data that is displayed in the filtered PivotTable report.
Slicers are typically associated with the PivotTable in which they are created. However, you
can also create stand-alone slicers. A slicer typically displays the following elements:
1. A slicer header indicates the category of the
items in the slicer.
2. A filtering button that is not selected indicates
that the item is not included in the filter.
3. A filtering button that is selected indicates that
the item is included in the filter.
4. A Clear Filter button removes the filter by
selecting all items in the slicer.
5. A scroll bar enables scrolling when there are
more items than are currently visible in the slicer.
6. Border moving and resizing controls allow you to
change the size and position

Create a slicer in an existing PivotTable
•

Click anywhere in the PivotTable report for which you want to create a slicer.
This displays the PivotTable Tools, adding an
Analyze and a Design tab.

•

On the Analyze tab, in the Filter group, click
Insert Slicer.

•

In the Insert Slicers dialog box, select the
check box of the PivotTable fields for which
you want to create a slicer.

•

Click OK.

•

A slicer is displayed for every field that you selected. In each slicer, click the items on
which you want to filter. To select more than one item, hold down CTRL, and then
click the items on which you want to filter.
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Timeline
Instead of playing around with filters to show dates, you can now use a PivotTable timeline.
It’s a box you can add to your PivotTable that lets you filter by time, and zoom in on the
period you want.
Much like a slicer you create to filter data, you can insert a timeline once and keep it with
your PivotTable
•
•
•

Click anywhere in a PivotTable to show the PivotTable
Tools.
Click Analyze and click on Insert Timeline.
In the Insert Timelines dialog box, check the boxes of the
date fields you want and click OK.

Use a timeline to filter by time period
With your timeline in place, you’re ready to filter by a time period in one of four time levels
(years, quarters, months, or days).
•

Click the arrow next to the time level shown, and pick the one you want.

•
•

Drag the timeline scroll bar to the time period you want to analyse.
In the timespan control, click a period tile and drag to include additional tiles to
select the date range you want. Use the timespan handles to adjust the date range
on either side.
To clear a timeline, click the Clear Filter button.

•

Tip If you want to combine slicers with a timeline to filter the same date field, you can do
that by checking the Allow multiple filters per field box in the PivotTable Options dialog box
(PivotTable Tools > Analyze > Options > Totals & Filters tab).
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Customize a timeline
When a timeline covers your PivotTable data, you can move it to a better location and
change its size. You can also change the timeline style, which may be useful if you have
more than one timeline.
• To move the timeline, simply drag it to the location you want.
• To change the size of the timeline, click it, and then drag the sizing handles to the
size you want.
• To change the style of the timeline, click it to display the Timeline Tools, and then
pick the style you want on the Options tab.
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Calculate values in a PivotTable report
Add a calculated field
•

•
•

Click the PivotTable report. This displays the
PivotTable Tools, adding the Analyze and Design
tabs. On the Analyze tab, in the Calculations
group, click Fields, Items, & Sets, and then click
Calculated Field.
• In the Name box, type a name for the field
• In the Formula box, enter the
formula for the field.
To use the data from another
field in the formula, click the
field in the Fields box, and
then click Insert Field. For
example, to calculate a 15%
discount on each value in the
Unit Cost field, you could
enter = Unit Cost * 15%.
Click Add.
Then click on OK.

Add a calculated item to a field
•

Click the PivotTable report. This displays the PivotTable Tools, adding the Analyze and
Design tabs.

•

Click the field where you want to add the calculated item.

•

On the Analyze tab, in the Calculations group, click Fields, Items, & Sets, and then click
Calculated Item.

•

In the Name box, type a name for the calculated item.

•

In the Formula box, enter the formula for the item.
To use the data from an item in the formula, click the item in the Items list, and
then click Insert Item (the item must be from the same field as the calculated item).

•

Click Add.
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Using Show Value As
Instead of writing your own formulas in calculated fields, you can use Show Values As to
quickly present values in different ways. It provides several calculation options, such as % of
Parent Total or % Running Total In.
Tip
You can use this feature to try different calculations in a value field. However,
because you can add the same value fields to a PivotTable more than once, you can
also use this feature to show the actual value and other calculations, such as a
running total calculation, side by side.
•

To add two or more of the same value fields to the PivotTable so that you can display
different calculations in addition to the actual value of a specific field, do the
following:
• In the Field List, drag the value field that you want to add to the Values area
that already contains that value field, and then place it right below that field.
Note The value field is added to the PivotTable and a version number is
appended to its field name. You can edit the field name as needed.
• Repeat the above step until you have displayed all the value fields you want
to calculate by using Show Values As.

•

Right click on the field and
choose Value Field Settings
Click on the Show Value As tab.
This is currently set to No
Calculation.
Select the required calculation
and click on OK

•

•
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The following calculation options are available in value fields:
Calculation option
No Calculation
% of Grand Total
% of Column Total
% of Row Total
% Of
% of Parent Row Total
% of Parent Column Total
% of Parent Total

Difference From
% Difference From
Running Total in
% Running Total in
Rank Smallest to Largest

Rank Largest to Smallest

Index
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Result
Displays the value that is entered in the field.
Displays values as a percentage of the grand total of all the
values or data points in the report.
Displays all the values in each column or series as a percentage
of the total for the column or series.
Displays the value in each row or category as a percentage of
the total for the row or category.
Displays values as a percentage of the value of the Base item in
the Base field.
Calculates values as follows:
(value for the item) / (value for the parent item on rows)
Calculates values as follows:
(value for the item) / (value for the parent item on columns)
Calculates values as follows:
(value for the item) / (value for the parent item of the selected
Base field)
Displays values as the difference from the value of the Base
item in the Base field.
Displays values as the percentage difference from the value of
the Base item in the Base field.
Displays the value for successive items in the Base field as a
running total.
Calculates the value as a percentage for successive items in the
Base field that are displayed as a running total.
Displays the rank of selected values in a specific field, listing the
smallest item in the field as 1, and each larger value with a
higher rank value.
Displays the rank of selected values in a specific field, listing the
largest item in the field as 1, and each smaller value with a
higher rank value.
Calculates values as follows:
((value in cell) x (Grand Total of Grand Totals)) / ((Grand Row
Total) x (Grand Column Total))
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Notes
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