Ally Accessibility Fixes

Remediating content at the source
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Introduction

The purpose of this guide is to demonstrate the issues that will be flagged by the Ally
software in Canvas, and how to fix them at the source eg via Word, PowerPoint, or Canvas.
There are separate guides available about fixing issues through the Ally software. You can

contact sophie.gahan@ucc.ie for a copy of these. Alternatively, you can view the Ally
Adoption Toolkit here.

Word
Accessibility Checker

When you are editing a Word Document for accessibility, start by running an Accessibility
Check. This is located under the Review tab.

File Home Insert Draw Design Layout References Mailings | Review | \
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Editor — Read Check Translate Language New
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A list of different issues will appear, you can expand these using the arrows on either side.

Accessibility v X
Inspection Results

Errors

issing alternative text

Content Placeholder 7 E
Content Placeholder 6 v

> No header row (1)
Warnings

5 Merged or split cells in table
m

In the following section, we will explain each of the issues that may arise during an
Accessibility Check or Ally review.
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Types of Issues

Colour Contrast

Colour contrast refers to the ratio of foreground text colour against the background colour
on a webpage or document. It is best to avoid bright text and highlight colours. Stick to
black font, on a white/grey background, where possible and use blue for links.

The Accessibility Checker will alert you to any contrast issues with your text. You can correct
any issues from within the Checker.

“ B -
Accessibility v X
Inspection Results

> No header row (1)

Warnings
> Merged or split cells in table

1)

~ || Hard-to-read text contrast
One common error in a... v

Intelliaent S¢ Recommended Actions

Automatic
L A Font Color >
Theme Colors a Page Color >
N EEEENEE )
Other Suggestions
@ Learn more
[ | I I I I I I I I\sl makes text easier to
then viewing documents in
Standard Colors
HE EEEEE
yut making documents
More Colors...
e i >
o D Gradient ¥ v o

For more information on colour contrast ratios, visit WebAimChecker.org

Headings

Properly formatted Headings in a document allow a screenreader to navigate the content
more easily and skip to sections as necessary. A screenreader can extract a list of all the
Headings in a document, which can be read aloud to the user. If pre-formatted Headings
aren’t used, this is not possible. For example, using bold and underline won’t enable this list
to be generated.

Headings can be added from the Styles gallery, which is underneath the Home tab in Word.
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https://webaim.org/resources/contrastchecker/

Headings work in a hierarchy, meaning the largest is Heading 1 and the smallest is Heading
5. A Heading 2 must always have a Heading 1 above it in the document structure. A Heading
2 can follow any other heading as long as there is a Heading 1 in the hierarchy and the
hierarchy is maintained.

Heading Styles can be customised and saved in a format of your choice. See the Microsoft
Support documentation for more information.

Alt Text

Alt Text is the text description of an image that is provided to a screenreader. You can add
Alt Text to any images or graphics that you include in a Word Document by right-clicking the
image and selecting Edit Alt Text.
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For more information, you can watch our session on Alt Text here.
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Tables

1. Headers
If you can Tab smoothly through a table, cell by cell and row by row, a screen reader should
have no trouble with it. Designated header rows make it easier for a screen reader to
navigate your table, and some screen readers will call out the name of a row or column
before reading the data.

You can assign a Header Row or Header Column by clicking the table and selecting the
Table Design tab.
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Under Table Properties, check Repeat as header row at the top of each page.

Also, be sure Allow row to break across pages is unchecked.

Table Properties ? X
Table Row Column Cell Alt Text
Rows 1-3:
Size
] Specify height: 0 cm /| Row height is: | At least b
Options

DZAIIOW row to break across pagesf

Repeat as header row at the top of each page

4 Previous Row w Next Row

2. Merged/Split Cells
Another item that may be flagged in your Accessibility Checker is merged/split cells. Screen
readers make sense of information in a linear way. They read tables from top to bottom, left
to right.
Using merged or split cells in your table confuses the reading order and can make your
information difficult to follow. Instead, consider breaking down your information into
multiple simple tables (with no merged or split cells) or rethink how you are presenting the
information.



] -
Accessibility %
Inspection Results

> No header row (1)

} Warnings

N IMerged or split cells in table I
able Ce

> Hard-to-1 Recommended Actions
Intelligent Se  F Merge Cells
> s Other §

v Keep accessil @ Learn more
I work -

Note: It is not possible to fix the merged cells issue within the Accessibility Checker without
running into an issue with split cells, and vice versa. This can be fixed via the licensed
version of Adobe Acrobat by changing the scope attribute of the merged or split cells.

Setting a Title

A title on a document makes it easier to understand for users with visual impairments. It is
more descriptive than the file name. If multiple documents are open at once, a title allows
the screenreader to quickly navigate through all files before opening a specific one.

To set a title on a Word Document, select File and Info. In the Properties section, click the Add a
Title field to add a document title.
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Setting a Language

Setting a language on a document not only informs the spellchecker of how to manage
edits, but it also informs a screen reader of what language to select when reading the
content aloud.

To select all the text in the document, go to the Home tab, choose Editing>Select and Select
All. With all the text selected, go to the Review tab, select Language and select the Set
Proofing Language option.
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selected text.

We'll remember to use this
language every time we check
spelling and grammar.

Once the Language dialog box opens, select the language that the text is written in.
Note: If you frequently use this language for other documents, select Set As Default.

To further facilitate language detection, unselect 'Do not check spelling or grammar' and
select 'Detect language automatically'.



PowerPoint

Accessibility Checker
Similar to word, the Accessibility Checker in PowerPoint is located under the Review tab.

File Home  Insert Draw  Design  Transitions  Animations  Slide Show  Record
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Types of Issues
All of the same principles listed above will show in the Accessibility Checker i.e Colour
Contrast, Alt Text, and Tables. PowerPoint will also flag Slide Titles and Reading Order.

Slide Titles
If pre-formatted slide titles have not being used during a PowerPoint design, then the
Accessibility Checker will recommend that they are added.

To resolve this issue, simply click on the slide number, in the AC review.
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A new panel will appear to the left of your presentation. You can insert slide titles by typing
directly into this area. Note: these titles will also be added to your slides.

1 Introduction
2 Objectives
3] Theory 1|

4

5

6



Alternatively, if you already have a title on your slide, but it is a simple textbox, you can use
the Accessibility Checker to ‘Set as Slide Title.” Use the dropdown arrow next to the issue to
do this.
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Other Suggestions
Additional

Why Fix? @ Learn more

Slide titles are used for navigation and
selection by those who are not able to view
the slide.

3 Steps To Fix:

Choose the Slide Title command from the

Reading Order

The Reading Order in PowerPoint refers to the layout of the elements on each slide. You
must let the end user know what comes first. You can adjust this through the Accessibility
Checker.

Accessibility v X

Inspection Results

~  Check reading order
Slide 1
Slide 2
Slide 3
Slide 4
Slide 5
Slide 7
Slide 8
Slide 10
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You can adjust this by using the dropdown arrow next to the issue and selecting ‘Verify
Object Order’.
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Accessibility v X
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A Reading Order panel will appear to the right of your presentation. Untick any items that
do not need to be read aloud. You can drag and drop the read-aloud content in the
preferred order.
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A Picture Placeholder 16

A Rectangle 18

A Rectangle 20

A Rectangle 21

Rectangle 14: Are we there yet?
A Straight Connector 15
Rectangle 11: Digital Inclusion a...
A Picture 3

Title 1: Introduction

KKKRKRKREE
W ® ~ S U AW N =



Canvas

Accessibility Checker

The Accessibility Checker is built-in to the Rich Content Editor (RCE) in Canvas. The RCE is
used in all Announcements, Assignments, Discussions, Pages, Classic Quizzes, and the
Syllabus. As you are creating/reviewing content in Edit mode in the RCE, the Accessibility
Checker will flag any reading issues with you.

Page title

Introduction

Edit View Insert Format Tools Table

24pt ~  Paragraph v B 7 U Av £v T2v F~ BV By BAv 8~ S & P

Welcome

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Phasellus varius elementum magna. Phasellus mattis id magna sit

amet malesuada. Vivamus massa nunc, fringilla rhoncus libero non, iaculis convallis nulla. Nullam aliquet lorem ac vulputate  ~
18
p» span @ | 805words </>

You can click this symbol to step through each issue and resolve it through the Checker. A
pop-up window will appear on the right. From here, you can select an alternative display
and the Apply button will become available once the edit meets Accessibility standards.

Page title
Accessibility checker

Introduction

Edit View Insert Format Tools Table Issue 1/18 @

24pt ~  Paragraph v B I U Av £+ T?v P~ BV Gav B

Text smaller than 18pt (or bold

OSBRI . Phasellus varius elementum mag 14pt) should display a minimum
amet malesuada. Vivamus massa nunc, fringilla rhoncus libero non, iaculis convallis nulla. contrast ratio of 4.5:1.
ullamcorper. Pellentesque ornare tristique nunc eu convallis. Sed dictum est posuere, dig

augue. Sed interdum purus a pharetra hendrerit. Etiam venenatis urna vitae orci venenat Change text colour
Maecenas eu sagittis nunc. Vestibulum ornare accumsan molestie. Mauris eget erat finib rgh(37, 32, 37)
p» span E

Options Users allowed to edit this page
Only teachers v

() Add to student to-do

Prev Next Apply

[0 Notify users that this content has changed

The Ally software will work in tandem with the Canvas Accessibility Checker to highlight
issues. Note: sometimes Ally will flag an issue that has not being caught by Canvas. This is
because Ally has higher thresholds for things like Colour Contrast. For that reason, it is best
practice to do a final review of content through Ally.
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PDF
Tagging

Tagging is the most common issue with PDFs, to be flagged by Ally. Tags are an invisible

layer of formatting that create a logical reading order for a screen reader. They are

applied to content such as Tables, Figures, Artifacts and Lists. Each tag identifies the type

of content and stores some attributes about it. They also arrange the document content

into a hierarchical architecture (or a “tag tree”). You do not need advanced editing

skills to apply these changes. SensusAccess UCC will generate tags for you.

Sensus

alternate media made easy

Library
Leabharlann

&UC

o s e v
CONVERT DOCUMENTS TO
ALTERNATIVE MEDIA

CALLY CONVERT DOCUM

AUTOMATIC ENTS INTO A RANGE
OF ALTERNATE MEDIA INCLUDING AUDIO BODKS. E

ED TO CONVERT
A5 IMAGE-ONLY RDF
SCFT POWERPQINT

Now Available for ALL Students &
staff of UCC

https//libguides ucc.ie/sensusaccess

.2 Convert a File Now using SensusAccess

Options

Target format: | pdf - Tagged PDF (image over text) v |

A demonstration of SensusAccess can be found at 8:50 mins of this video.

Note: where possible, it is best to share content in the original Word document, rather than

converting to PDF.
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https://libguides.ucc.ie/sensusaccess/convertfile
https://ucc.cloud.panopto.eu/Panopto/Pages/Viewer.aspx?id=2211c270-feb5-470c-bf40-af0f00ae6c74

Video

Captions
Captions can be added retrospectively to your videos in Panopto using Automatic Speech
Recognition, alternatively you can upload a caption file.

To add automatic captions, select the Captions button from the left-hand panel when using
Edit Mode in Panopto.

Details Language: English (United States) ¥
Contents Import captions E
Import automatic captions
e Upload or request captions
Quizzes
Cuts
Streams

Select Import Automatic Captions to generate captions for your video. Once complete, you
can click directly into any paragraph to edit the captions.

Details Language: English (United Kingdom) ~ Q
Contents Import captions ¥

Audio So. Hello, everyone, and welcome. So s 024
Descriptions hello everyone and welcome to this

Slides session on unique descriptive links.

Quizzes This is part of our Quad series, which 0:53
Cuts runs every Tuesday in October.

Streams And so say we're doing you. 0:57

14


https://support.panopto.com/s/article/Manually-upload-Captions

Resources
Legislation related to accessibility

e EU Web Accessibility Directive (lrish context)
e The Web Content Accessibility Guidelines 2.0

e The Universal Design for Learning Guidelines

Support Services

e Microsoft Support
e Panopto Support

e Canvas Support
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https://nda.ie/publications/communications/eu-web-accessibility-directive/
https://nda.ie/publications/communications/eu-web-accessibility-directive/
https://www.w3.org/TR/WCAG20/
https://udlguidelines.cast.org/
https://support.microsoft.com/en-us
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https://community.canvaslms.com/t5/Instructor-Guide/tkb-p/Instructor
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