Excel 2010
Sorting and Filtering

Computer Training Centre, UCC, tcentre@ucc.ie, 021-4903749/3751/3752
# Table of Contents

## Sorting Data
- Sort Order ........................................................................................................... 1
- Sorting by Cell Colour, Font Colour or Cell Icon.................................................... 2

## Sorting using Custom Lists
- Using a Built in Custom list .................................................................................. 3
- Creating a User defined Custom List ....................................................................... 4
- Delete a Custom List ............................................................................................... 4

## AutoFilter
- Create criteria ......................................................................................................... 5
- Clear Criteria .......................................................................................................... 5
- Clear a filter for a column ........................................................................................ 5
- Clear all filters in a worksheet and redisplay all rows ............................................ 5
- To turn off the AutoFilter ....................................................................................... 6

## Advanced Filter
- One condition in two or more columns ................................................................. 7
- One condition in one column or another ............................................................... 7
- One of two sets of conditions for two columns ..................................................... 7
- More than two sets of conditions for one column ............................................... 8
- To turn off the Advanced Filter ............................................................................. 9
Sorting and Filtering Excel 2010

Sorting Data
You use the Sort command to arrange the rows of a data list alphabetically or numerically in ascending or descending order, based on the contents of the fields, or columns. **Ascending** will sort the lowest number, the beginning of the alphabet, or the earliest date first in the sorted range. **Descending** will sort the highest number, the end of the alphabet, or the latest date first in the sorted range. Blank cells are always sorted last.

- Click into a cell within the column you wish to sort.
- Click on the **Home** Tab and then click the down arrow to right of the **Sort & Filter** command button located to the right of the screen within the Editing group.

**Note:** for more detailed sorting select **Custom Sort..** or from the **Data** Tab click on the **Sort** command.

- On the **Data** tab, in the **Sort & Filter group**, click **Sort** to display the Sort dialog box shown. Because row 6 contains headings for our data columns, we check the **My Data Has Headers** box. We will now select the following four criteria in the order shown:
  - Sort by the **Surname** column so that **Values** (this means cell contents) are in **A to Z** order.
  - Sort by the **Forename** column so that **Values** are in **A to Z** order.
  - Click the **Add Level** button twice to give a total; of four levels
  - Sort by the **Gross Pay** column so that **Values** are in order from Largest to Smallest.
  - Sort by the **Tax** column so that **Values** are in order from Largest to Smallest.

Sort Order
The Sort Orders Options depend on the data type of the column you are sorting on.

- For text values, select A to Z or Z to A.
- For number values, select Smallest to Largest or Largest to Smallest.
- For date or time values, select Oldest to Newest or Newest to Oldest.
Sorting by Cell Colour, Font Colour or Cell Icon

In Excel 2010 you can also sort by Cell Colour, Font Colour or Cell Icon (Conditional Formatting).

- Click on the arrow to the right of **Values** under the **Sort On** heading.

- Select the required option for example if you wish to sort on **Cell Colour** (the cell colour should already be applied, possibly by using the Condition Formatting feature).

- By choosing the options shown below any cell within the column division coloured green will be position to the top of the list, those with no cell colour in the middle and those with a cell colour red at the bottom of the list.

- Click on **OK**
Sorting using Custom Lists

You can use a custom list to sort in a user-defined order. For example, a column might contain values that you want to sort by, such as High, Medium, and Low. How can you sort so that rows containing High appear first, followed by Medium, and then Low? If you were to sort alphabetically, an “A to Z” sort would put High at the top, but Low would come before Medium. And if you sorted “Z to A,” Medium would appear first, with Low in the middle. Regardless of the order, you always want “Medium” in the middle. By creating your own custom list, you can get around this problem.

In addition to custom lists, Excel provides built-in, day-of-the-week and month-of-the-year custom lists.

Using a Built in Custom list

If you wish to sort the data to the right by month by using the A to Z, April would appear first etc. In order to use the months of the year built in list:

- Select a cell within the list
- Display the sort dialogue box
- Click on Custom Lists.. from the Order drop down list
- Click OK
- The following is then displayed

- Choose the January, February option from the Custom lists and click on OK twice
- The data is now sorted according to the calendar month.
Creating a User defined Custom List

You can use a custom list to sort in a user-defined order.

- In a range of cells, enter the values that you want to sort by, in the order that you want them, from top to bottom.
- Select the range that you just entered.
- Click the File tab, click Options, and then click the Advanced category.
- Scroll down to the General heading, click Edit Custom Lists... button.
- In the Custom Lists dialog box, click Import (Alternatively, you can type the values directly into the List entries box pressing enter after each entry instead of importing them from a range of cells in a worksheet.)
- Click OK twice.
- Carry out the steps previously previously outlined to use the list the built in list for sorting.

Note: the Custom List that you have just added will remain in the Custom Lists dialogue for any further workbooks.

Delete a Custom List

To permanently remove a custom list

- Click on the list on the left hand side of the Custom List dialogue box
- Click on the Delete button, a warning is displayed, click on OK then OK again.
AutoFilter
The AutoFilter feature puts drop-down arrows (with menus) in the titles of each column. The menus are used to select criteria in the column so that only records that meet the specified criteria are displayed.

- Select a cell within the list.
- On the Home tab, in the Editing group, click Sort & Filter, and then click on the Filter command. An arrow appears to the right of each column label.
- To display only the people in the MIS department, remove the tick next to Select All, and select MIS from the list.

Create criteria

- Point to Text Filters and then click one of the comparison operators or click Custom Filter.
- For example, to filter by text that begins with a specific character, select Begins With, or to filter by text that has specific characters anywhere in the text, select Contains.
- In the Custom AutoFilter dialog box, in the box on the right, enter text or select the text value from the list. Optionally, filter by one more criteria.

How to add one or more criteria

- To filter the table column or selection so that both criteria must be true, select And.
- To filter the table column or selection so that either or both criteria can be true, select Or.
- In the second entry, select a comparison operator, and then in the box on the right, enter text or select a text value from the list.

Clear Criteria

You can clear a filter for a specific column or clear all filters.

Clear a filter for a column

- To clear a filter for one column in a multicolumn range of cells or table, click the Filter button on the column heading, and then click Clear Filter.

Clear all filters in a worksheet and redisplay all rows

- On the Data tab, in the Sort & Filter group, click Clear.
To display a list of Employees with a Tax liability less than 3,500

- From the Tax Column, select Number Filters and select Custom Filter.
- In the Custom AutoFilter dialog box, select the “is less than” option by clicking on the arrow under Tax to display the drop-down list.
- Type 3500 and click OK. Ten records match the criteria.
- To show all records again, select the Tax drop down arrow, and Clear Filter from “Tax”.

To turn off the AutoFilter

- On the Home tab, in the Editing group, click Sort & Filter, and then deselect Filter.
Advanced Filter

The AutoFilter command on the Home Tab is usually the quickest way to filter a list. However, if you want to filter a list using multiple sets of criteria or criteria containing formulas use the Advanced Filter command on the Data Tab.

The Advanced Filter enables you to filter data by using a criteria range to display only the rows that meet all the criteria you specify.

One condition in two or more columns

To find data that meets one condition in two or more columns, enter all the criteria in the same row of the criteria range.

<table>
<thead>
<tr>
<th>Department</th>
<th>Surname</th>
<th>Forename</th>
<th>Gross Pay</th>
<th>Tax</th>
<th>Pension</th>
<th>Net Pay</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accounts</td>
<td></td>
<td></td>
<td></td>
<td>&gt;3200</td>
<td>&lt;8000</td>
<td></td>
</tr>
</tbody>
</table>

*E.g.* this criteria range displays all rows that contain "Accounts" in the Department column, with a tax value **greater than €3,200** in the Tax column, and **Net Pay less than €8,000**.

in one column or another

To find data that meets either a condition in one column or a condition in another column, enter the criteria in different rows of the criteria range.

<table>
<thead>
<tr>
<th>Department</th>
<th>Surname</th>
<th>Forename</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accounts</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Forde</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alan</td>
<td></td>
</tr>
</tbody>
</table>

*E.g.* this criteria range displays all rows that contain either "Accounts" in the Department column, "Forde" in the Surname column or "Alan" in the Forename column.

One of two sets of conditions for two columns

To find rows that meet one of two sets of conditions, where each set includes conditions for more than one column, type the criteria in separate rows.

<table>
<thead>
<tr>
<th>Department</th>
<th>Surname</th>
<th>Forename</th>
<th>Gross Pay</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accounts</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>&gt;=13000</td>
</tr>
<tr>
<td>Personnel</td>
<td></td>
<td></td>
<td>&gt;12000</td>
</tr>
</tbody>
</table>

*E.g.* this criteria range displays the rows that contain both "Accounts" in the Department column and Gross Pay **greater than or equal to €13,000**, and also displays the rows for Personnel Department with Gross Pay **greater than €12,000**.
More than two sets of conditions for one column

To find rows that meet greater than two sets of conditions, include multiple columns with the same column heading.

<table>
<thead>
<tr>
<th>Gross Pay</th>
<th>Gross Pay</th>
</tr>
</thead>
<tbody>
<tr>
<td>&gt;14000</td>
<td>&lt;15000</td>
</tr>
<tr>
<td>&lt;12000</td>
<td></td>
</tr>
</tbody>
</table>

\[\text{e.g. this criteria range displays } \text{Gross Pay} \text{ that are between } €14,000 \text{ and } €15,000 \text{ in addition to Gross Pay that are less than } €12,000.\]

As an example, we will extract from the list all Employees whose Gross Pay is greater than €14,000 from the Personnel Department and also employees from the Marketing Department with a Gross Pay greater than €13,000

- Insert several blank rows at the very top of your worksheet. (Your column headings should now be on row 10 of the worksheet)
- Select the column headings in Row 10 and copy. Paste the headings into Row 1 of the worksheet.
- Enter the criteria for the advanced filter as follows;

<table>
<thead>
<tr>
<th></th>
<th>Department</th>
<th>Surname</th>
<th>Forename</th>
<th>Gross Pay</th>
<th>Tax</th>
<th>Pension</th>
<th>Net Pay</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Personnel</td>
<td></td>
<td></td>
<td>&gt;14000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Marketing</td>
<td></td>
<td></td>
<td>&gt;13000</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- Click into any cell within the list and then select the Data tab. In the Sort & Filter group choose Advanced Filter...
- Ensure that the List Range is $A$1:$G$29
- The Criteria Range - specifies the range of cells on your worksheet that contains your criteria. In this example it should be $A$1:$G$3, to ensure this click into the Criteria range box and then with the mouse click into cell A1 of the worksheet and highlight to cell G3.
- Under the heading Action there are 2 options:
  - Filter the list, in-place - hides the rows that do not meet the criteria and the filtered list is displayed where the existing List range had been displayed.
  - Copy to Another Location copies the filtered data to another worksheet or another location on the same worksheet. If this option is selected the Copy to: box will no longer be greyed out and you click into this box and select where you wish the filtered list to appear.
- Click OK. This will return you to the worksheet, and display the records that match the criteria. (Three records meet the criteria)
To turn off the Advanced Filter
From the Data tab in the Sort & Filter Group click on Clear.

EXERCISES
Remember to clear the filter after each exercise.

Use the AutoFilter to solve the following:

1. Search for Employees with a Net Pay greater than €8000 and who are in the Accounts Department.
   Two records match the criteria – Mary Forde and Elizabeth Murphy.

2. Search for Employees with Tax greater than €3000 and whose Net Pay is greater than €9000.
   Two records match the criteria

3. Search for Employees who are in either the Accounts or Personnel departments.
   Eight records match the criteria

Use the Advanced Filter to solve the following:

1. Search for Employees working in the Personnel Department, with a Net Pay that is less than €7,500 and employees working in the Admin Department, with a Net Pay of more than €7,500. Filter the list in place.
   Four records match the criteria.

2. Search for Employees working in the Accounts Department, paying more than €3,500 Tax and employees working in the Marketing Department, with a Pension of less than €1,300. Copy the filter results to cell J2.
   Three records match the criteria.